Install Micropython

Hi everybody,
I would like to do some python with my brainpad (Rev A.):

But Nothing append: no serial port appears.

Any help would be appreciated :wink:

It should simply work! There is nothing special there.

It should, but I Don’t have any drive or COM port appearing !

I’ve tried:

But nothing better: no sound when I reset board, no drive, no unknown device in device manager. :sob:
I’m on Win 10 64bits in case it can help.

1 Like

checked on source code

// UART config
#define MICROPY_HW_UART2_TX (pin_A2)
#define MICROPY_HW_UART2_RX (pin_A3)
#define MICROPY_HW_UART6_TX (pin_C6)
#define MICROPY_HW_UART6_RX (pin_C7)
// UART 2 connects to the STM32F103 (STLINK) on the Nucleo board
// and this is exposed as a USB Serial port.
#define MICROPY_HW_UART_REPL PYB_UART_2
#define MICROPY_HW_UART_REPL_BAUD 115200

i belive you can use with any UART (PA2,PA3) to use Micropython on BrainPad

Last time I tried this kit worked over USB. Not sure what had changed.

@gus_issa I have succeeded to build v1.9.1, you used on video and it works. I will try to find Which version is broken (for brainpad).

USB and com port can’t be accessible since v1.9.4.
But it can be enable by adding two lines in mpconfigboard.h (from 1.9.4 to actual master):

#define MICROPY_HW_HAS_SWITCH       (1)
#define MICROPY_HW_HAS_FLASH        (1)
#define MICROPY_HW_ENABLE_RTC       (1)
#define MICROPY_HW_ENABLE_USB       (1)

and:

// USRSW is pulled low. Pressing the button makes the input go high.
...

// USB config
#define MICROPY_HW_USB_FS (1)

// LEDs
...

So now, I can play with it ! :smile:

2 Likes

share compiled firmware :slight_smile:

I’ve trouble with blue led of light bulb. But as soon as it’s done, be sure I will share it ! :wink:

2 Likes

When you are done we should talk. We have done some work internally. We should join forces on this.